• .
Hallo, Gast! Anmelden Registrieren


CSR8645-TPA3116-Amplifier Board
#1
Hallo,

wie bereits hier angekündigt: https://stromrichter.org/d-amp/include.p...post152634 habe ich mir auch einen fertigen Amplifier aus Fernost bestellt.

Dabei handelt es sich um ein Modul ausgestattet mit einem TPA3116 und einem CSR8645- Bluetooth Modul sowie Beschaltung zum Betrieb.

[Bild: 75_IMG_1617_low_q.jpg]
(Auf dem Foto ist bereits der Kühler entfernt und eine Programmierschnittstelle hergestellt)

Erstes Einschalten:

- lautes Lautsprecherrauschen
- ne Menge Störgeräusche, die sich aus dem Netzteil in die Schaltung eingekoppelt haben.

Die Fehler am Board verhalten sich im Prinzip analog zu denen aus diesem Thread, der TE hat das schon sehr gut beschrieben:
https://stromrichter.org/d-amp/include.p...post152632

Für den Versuch einer Verbesserung nach Vorlage des oberen Thread ist der Signalweg nachgemessen und auf Seite 1 des Anhangs dargestellt (Ja, ist mit Word gemacht).

Auf Seite 2 ist die veränderte Schaltung aufgeführt.Grün ist der neue Signalpfad, Rot der alte. Das Kondensatorlogo soll bedeuten, das ich die Kondensatoren hochgeklappt hab und diese nur noch auf einem Lötpad stehen- sonst hat man die leider nicht ganz aus dem "alten" Signalweg bekommen.

[Bild: 149_Improved_low_q.jpg]

Zusätzlich habe ich den Gain des Verstärker reduziert- anstatt 100k:40K ist der Spannungsteiler auf 100k:10k eingestellt. Der OP-Amp ist drauf geblieben, aber bekommt keine Versorgungsspannung mehr, da Torwiderstand fehlt.

Erfolge:
- Die Störgeräusche aus dem Netzteil bleiben gänzlich aus.
- Ohne Musik quasi kein Rauschen
- Aux geht dank Änderung der PSKeys auch   Big Grin

Als dritten Anhang lege ich mal ein Backup der Factory-PSKeys bei. Vielleicht braucht sie jemand. Für weiteres Vorgehen sind zwei Visaton FRS-8 bestellt. Mal gucken was da geht   ;pop;corn;


Angehängte Dateien
.pdf   CSR8645_TPA3116_ChinaBoard_Modi.pdf (Größe: 753,26 KB / Downloads: 127)
 
Reply
#2
Wie schauts denn mit den Störungen des BT-Moduls aus?
...mit der Lizenz zum Löten!
 
Reply
#3
Zitat:Original geschrieben von voltwide

Wie schauts denn mit den Störungen des BT-Moduls aus?

So, Anhänge sind jetzt auch da.

Das Netzteilpfeifen ist seitdem der OP rausgeflogen ist weg. Der Signalweg ist von der Länge her quasi gleich lang, ausschlaggebend scheint also das Bauteil mit Beschaltung zu sein. Man kann quasi überall auf der Schaltung rumfingern ohne das es Geräusche gibt- außer halt beim Aux.

Danach gab es noch "Leerlaufrauschen", das habe ich mit Änderung des Gain-Spannungsteiler in den Griff bekommen. Jetzt kann man das Ding auch nebenbei laufen lassen, ohne das einen die Lautstärke auf den Geist geht. Gemessen habe ich es nicht- aber ich bilde mir ein, das der kleine IC im Leerlauf nun auch "kalt" bleibt. Vorher hat der sich auch beim Programmieren ohne Musik immer ordentlich erwärmt.


Probleme mit Ein- und Ausschaltploppen habe ich auch nicht.

[Bild: 86_Screenshot.jpg]

Batteriespannung des Empfängers gibt er auch mit- geiles Feature, wenn da nicht ein Festspannungsregler vor wäre lachend

Aux läuft auch. Solang kein Signal vom Endgerät kommt kann per Aux eingespielt werden-auch wenn die schon gekoppelt sind.
 
Reply
#4
Hast du den kompletten Dump von mir übernommen ?
 
Reply
#5
Zitat:Original geschrieben von christianw.

Hast du den kompletten Dump von mir übernommen ?

Nope, lief nicht. Mit deinem Dump war das Bluetooth Modul nicht sichtbar. Wesentliche Unterschiede waren bei den DSP-Keys und ein paar USR-Keys. Musste die für das Bartteriemanagement tauschen um ein Lebenssignal zu bekommen.
Mir fällt grad auf, den Factory Dump habe ich vergessen. Hängt an.

Aber ja, für das Aux habe ich mich bei dir bedient Smile Ist ja im
Prinzip alles aus deinen Beiträgen ausgegangen, was ich bisher geändert habe.
 
Reply
#6
Was da los mit deinen Anhängen?

Zitat:Musste die für das Bartteriemanagement tauschen um ein Lebenssignal zu bekommen.

Welcher sind das? Mir war so, als könnte man auch einen ADC am PIO dafür hernehmen, womit man dann extern Akku überwachen kann.
 
Reply
#7
Zitat:Original geschrieben von christianw.

Was da los mit deinen Anhängen?

Zitat:Musste die für das Bartteriemanagement tauschen um ein Lebenssignal zu bekommen.

Welcher sind das? Mir war so, als könnte man auch einen ADC am PIO dafür hernehmen, womit man dann extern Akku überwachen kann.

Gute Frage. Hab jetzt auf Firefox gewechselt.

USR10 war ausschlaggebend, ich habe nach und nach getauscht und ab dann ging es. Den Aufbau des Keys habe ich mir nicht angeguckt.
Dem Headsettool zufolge ist es so wie du gesagt hast. Aber kein Target für heute, ist mir nur heute positiv aufgefallen.


Angehängte Dateien
.zip   csr_8645.psr.zip (Größe: 8,14 KB / Downloads: 37)
 
Reply
#8
Well Big Grin Wie Schon erwähnt soll das Board später zwei FRS-8 betreiben. Darauf warte ich noch.
Der FRS8 ist günstig und scheint im Netz auf große positive Resonanz zu stoßen. Zumal es diverse Bauvorschläge gibt. Allerdings alles recht große Gehäuse.

Damit man mal mit dem Volumina spielen kann ist folgender Aufbau entstanden:

[Bild: 130_bild.jpg]

Idee ist es den Treiber in das Endstück rechts einzulassen, und anschließend im laufenden Betrieb quasi mit dem linken Schieber das Volumen in der Doppelmuffe beliebig zwischen ca. 0,4 und 1,5 Litern einstellen zu können. Später soll die Frontplatte mit Bohrungen versehen werden- ne Art "Bassreflex".Also alles in allem Abstimmung per Ohr.Ziel ist ein möglichst kleines Gehäuse als Kompromiss zum Sound.

Kann man so machen oder ist ne blöde Idee?
 
Reply
#9
Man wird sicher immer das größte Volumen anstreben und auch hören.
 
Reply
#10
Zitat:Original geschrieben von christianw.

Man wird sicher immer das größte Volumen anstreben und auch hören.

Wie ist das mit dem Bassreflex? Was ich so im Hinterkopf habe ist das man dadurch noch Pegel rausholen kann. Bei den Lautsprechern die ich so zerlegt habe gehen die allerdings alle tief in den Körper hinein- macht das dann Sinn vorne zu bohren?
 
Reply
#11
Musste mal simulieren mit WinISD.
 
Reply
#12
Blöde Frage: welche (günstigen) Netzteile harmonieren gut mit den Modulen? Ich bekomme zwei Boards, die jeweils Mono einen Breitbänder mit max. 30W befeuern sollen (bzw. 50W, habe da unterschiedliche Angaben gefunden) . Realistischerweise rechne ich aber mit max. 10-20W Verstärkerleistung bei 86dB Kennschalldruck.
 
Reply
#13
ich befeuere solche amps mit abgelegten NotebookNetzteilen von Markernherstellern (Lenovo, HP, etc).
Aus der Restekiste.
Irgendeine Ausgangsspannung zwischen 16 und 24V.
Schutzleiter sollte durchgeschliffen sein zum Sekundärkreis:
3-poliger Netzanschluss!
...mit der Lizenz zum Löten!
 
Reply
#14
Das ist natürlich eine gute Idee - ich habe nur gerade keine ungenützten Notebook-Netzteile herumliegen. Gibts Empfehlungen für einen Neukauf?
 
Reply
#15
(06.06.2017, 09:38 AM)buyman schrieb: Das ist natürlich eine gute Idee - ich habe nur gerade keine ungenützten Notebook-Netzteile herumliegen. Gibts Empfehlungen für einen Neukauf?
guxtu ebay.de "notebook adapter lenovo"
...mit der Lizenz zum Löten!
 
Reply
#16
(06.06.2017, 09:38 AM)buyman schrieb: Das ist natürlich eine gute Idee - ich habe nur gerade keine ungenützten Notebook-Netzteile herumliegen. Gibts Empfehlungen für einen Neukauf?

Manchmal ist es auch ratsam, falls vorhanden, in der IT-Abteilung des Unternehmens mit einem Kaffee beim Ansprechpartner des Vertrauens vorbeizuschauen. Die haben immer irgendwas in der Ecke was aus dem Bestand schon rausgenommen ist und seit Jahren auf Verwendung wartet.
 
Reply
#17
Board heute erhalten - mit einem CSR 8630 motz

https://www.qualcomm.com/products/csr8630
https://www.qualcomm.com/products/csr8645


Gibt ja keinen Unterschied. Mal schauen, was der Chinese sagt. Rücksendung und complete Refund wird sich nicht lohnen. Ärgerlicher ist, dass ich jetzt nochmal sowas kaufen muss.  motz
 
Reply
#18
Blöde Frage: fängt dein CSR8645 Bord auch so viele Störungen ein wie meins mit dem CSR8630? Vor allem auf dem linken Lautsprecher hört es sich stark danach an, als würde der Mobilfunk gut einstrahlen. Ich hab den Gain jetzt aber noch nicht umgelötet.
 
Reply
#19
Eventuell koppelt die Antenne ein, du kannst es mal mit einem Kabel als Antenne probieren, like so:

http://www.diyaudio.com/forums/class-d/2...ost5114726

   
 
Reply
#20
Danke für den Tipp - werde ich heute Abend versuchen. Ein Argument mehr, um bei Ali Kohle einzufordern ... Falsches PCB, das zusätzlich noch lautstarke Störungen einkoppelt und damit "unbenutzbar" ist Wink

2$ haben sie mir angeboten die Chinesen ...
 
Reply